CyberPanel - бесплатная панель управления для VDS / VPS / сервера + LiteSpeed + Linux Ubuntu 18.04 / 20.04, Centos 7 / 8

sitecreator

Administrator
Команда форума
Сайт разработчика панели CyberPanel.
Процесс установки CyberPanel кратко описан здесь.

Разработчиком CyberPanel заявлена совместимость с операционными системами:
  • Centos 7.x,
  • Centos 8.x,
  • Ubuntu 18.04,
  • Ubuntu 20.04

CyberPanel работает совместно с веб-сервером OpenLiteSpeed (или с его коммерческой версией). OpenLiteSpeed понимает конфигурационные файлы Apache .htaccess, поэтому можно считать, что программное обеспечение, которое рассчитано на работу с Apache, будет также работать и под OpenLiteSpeed. Работа CyberPanel с Apache или Nginx не предусмотрена. Если говорить про быстродействие, то можно утверждать, что OpenLiteSpeed с успехом заменяет связку Nginx + Apache, т.е. по быстродействию он не уступает этой связке или отдельному Nginx, но превосходит по быстродействию Apache (если тот работает один без Nginx).

OpenLiteSpeed имеет расширение для Opencart, позволяющее использовать кеширование страниц средствами самого веб-сервера.

Выбирайте правильно операционную систему Linux нужной версии. Более старая версия поддерживает более старые версии php, а не только самые свежие. Если использовать Ubuntu 18.04 , то будут доступны php версий:
  • 7.0, 7.1 (с поддержкой mcrypt),
  • 7.2, 7.3, 7.4, 8.0 (без поддержки mcrypt).
Если же нужно использовать php 5.6, то тогда стоит установить Linux Centos 7.X, поддержка которой прекратится 01.01.2025.

ВАЖНО IMPORTANT
Важно понимать, что в случае Ubuntu 20.04 и использовании CyberPanel вам будут доступны для работы с веб-сервером OpenLiteSpeed только версии php (lsphpXX ): 7.2, 7.3, 7.4, 8.0. В этих версиях нет расширения mcrypt, необходимого для определенных версий Opencart, и вы не сможете самостоятельно его установить в отличие от случаев если бы вы использовали веб-сервер Nginx или Apache (но эти веб-серверы CyberPanel не поддерживает). Также вы не сможете установить другие более старые версии lsphpXX, например, lsphp56 или lsphp71.
Устанавливайте Ubuntu 18.04 если вам нужны php (lsphpXX ) 7.0, 7.1, в которых есть расширение mcrypt. Версии php 7.2...8.0 в Ubuntu 20.04 не содержат mcrypt.

Если нужны все версии PHP (5.3...8.0) с поддержкой mcrypt, то тогда нужно использовать ОС Centos 7.


Самый большой выбор версий PHP будет если установить Centos 7 + CeberPanel. От php 5.3 до php 8.0, что покрывает практически все потребности, особенно если используется движок Opencart старых версий. Для каждого сайта можно назначить свою версию php.

Примечательно, что в случае Centos 7 все версии PHP (LSPHP), включая php 8.0, имеют подключенное расширение mcrypt, чего нельзя сказать о варианте для Ubuntu.




CyberPanel установит автоматически сервер MariaDB. Но версия данного сервера будет зависеть от того какую ОС вы установили прежде. Для Centos 7 будет установлена самая свежая версия MariaDB 10.5 (актуальная на июнь 2021). Для Ubuntu 18.04 будет установлена MariaDB 10.1, а на Ubuntu 20.04 - MariaDB 10.3 соответственно, т.е. для Ubuntu устанавливаются те версии, которые доступны из репозиториев Ubuntu. Т.е. Centos 7 получается, что будет самым универсальным решением в плане PHP и будет иметь самый свежий софт по сравнению с Ubuntu, не смотря на то, что Centos 7 выпущена ранее Ubuntu 18.04.



На Ubuntu также можно обновить MariaDB до 10.5, но более сложным способом. В случае Centos 7 получается все проще и с более предсказуемым результатом.
На данный момент (июнь 2021) актуальная версия Centos 7 - это Centos 7.9 от 12 ноября 2020 с ядром Linux 3.10.0-1160. Поддержка (выпуск обновлений безопасности и стабильности) Centos 7 разработчиком заявлена до конца 2024 года.
Centos 8 также поддерживает CyberPanel, но поддержка Centos 8 заявлена лишь до конца 2021.


Перед установкой панели управления у вас должна быть установлена Centos 7 или Ubuntu 18.04, или 20.04.

Обновление репозиториев Ubuntu:
Код:
sudo apt update
Можем узнать какие пакеты могут быть обновлены:
Код:
apt list --upgradable
Для обновления системы используем:
Код:
sudo apt upgrade
или
Код:
sudo apt full-upgrade
Установите curl:
Код:
sudo apt install curl
Во время установки будет вопрос (выбираем Yes):

Проверьте версию установленного curl (для определения успешной установки):
Код:
curl -V
Перезагрузите Ubuntu:
Код:
reboot
Запускаем установку CyberPanel:
Код:
sh <(curl https://cyberpanel.net/install.sh || wget -O - https://cyberpanel.net/install.sh)
В ходе установки будет предлагаться разный выбор опций. Обычно все довольно прозрачно для понимания. На скриншотах ниже показаны большинство выбираемых опций. На запрос установки разных расширений PHP отвечаем "Y".




















По умолчанию (если при установке не меняли) пароль: 1234567.
Разумеется, что его нужно сменить.
Задать новый пароль админа панели управления CyberPanel :
Код:
adminPass newpassword
Узнать пароль для пользователя root для MySQL/MariaDB:
Код:
cat /etc/cyberpanel/mysqlPassword
Все пароли для входа в панели управления указаны в отдельных файлах в этой папке /etc/cyberpanel:

 
Последнее редактирование:

sitecreator

Administrator
Команда форума

Работа с CyberPanel на примере движка интернет-магазина Opencart



Вместе с CyberPanel был установлен веб-сервер OpenLiteSpeed и его панель управления WebAdmin.
Помимо этих 2-х панелей управления еще была установлена панель управления RainLoop — Admin Panel для работы с почтой.
Бесплатный веб-сервер OpenLiteSpeed понимает файлы кофигурации Apache .htaccess.

ВАЖНО IMPORTANT
Но с одним важным отличием. Веб-сервер Apache подхватывает на лету любые изменения в файлах .htaccess, а веб-сервер OpenLiteSpeed требует каждый раз его перезагрузки при каждой загрузке нового .htaccess или его изменения.



Веб-сервер можно перезагрузить двумя способами:
  • через панель управления CyberPanel
  • через панель управления веб-сервером OpenLiteSpeed
Оба способа показаны ниже.




Для перезагрузки OpenLiteSpeed нужно зайти в панель управления веб-сервером OpenLiteSpeed и сделать его перезагрузку.
Коммерческая версия LiteSpeed не требует перезагрузки, т.е. работает также как и Apache с .htaccess на лету.
Если сайтов немного и/или изменение файлов .htaccess происходит редко, то перезагружать OpenLiteSpeed обычно приходится крайне редко.

Панель управления OpenLiteSpeed - это отдельная от CyberPanel панель управления.
Параметры входа для нее вы видели после завершения установки CyberPanel. Ниже примерные данные для входа:

Код:
Visit: https://XXX.XXX.XXX.XXX:7080                  
WebAdmin console username: admin                
WebAdmin console password: XXXXXXXXXXX

OpenLiteSpeed панель управления веб-сервером WebAdmin


 
Последнее редактирование:

sitecreator

Administrator
Команда форума
Centos 7


Узнать версию установленной ОС Centos:
Код:
cat /etc/centos-release
Узнать версии установленного
python
Код:
ls -ls /usr/bin/python*
Результат:
Код:
0 lrwxrwxrwx 1 root root     7 Jun 10 02:56 /usr/bin/python -> python2
0 lrwxrwxrwx 1 root root     9 Jun 10 02:56 /usr/bin/python2 -> python2.7
8 -rwxr-xr-x 1 root root  7144 Nov 17  2020 /usr/bin/python2.7
0 lrwxrwxrwx 1 root root     9 Jun 10 03:02 /usr/bin/python3 -> python3.6
12 -rwxr-xr-x 2 root root 11328 Nov 16  2020 /usr/bin/python3.6
0 lrwxrwxrwx 1 root root    17 Jun 10 03:02 /usr/bin/python3.6-config -> python3.6m-config
12 -rwxr-xr-x 2 root root 11328 Nov 16  2020 /usr/bin/python3.6m
4 -rwxr-xr-x 1 root root   173 Nov 16  2020 /usr/bin/python3.6m-config
4 -rwxr-xr-x 1 root root  3403 Nov 16  2020 /usr/bin/python3.6m-x86_64-config
0 lrwxrwxrwx 1 root root    16 Jun 10 03:02 /usr/bin/python3-config -> python3.6-config


Для установки CyberPanel необходимо наличие python 3-й версии и pip3.
Проверить версию установленного python3:
Код:
python3 -V
Установить python3 если отсутствует:
Код:
yum install -y python3-devel.x86_64
Если python3 нет в репозиториях нет, то подключите EPEL.
Установить python3 можно, например, из репозитория EPEL.
Список репозиториев в ОС:
Код:
yum repolist
Подключить при необходимости:
Код:
yum install epel-release



Проверить версию установленного pip3:
Код:
pip3 -V
Установить при необходимости:
Код:
yum install python3-pip -y

Обновим компоненты ОС, предварительно очистив кеш менеджера пакетов yum:
Код:
yum clean all
Код:
yum -y update
Перезагрузим для надежности:
Код:
reboot
 
Последнее редактирование:

sitecreator

Administrator
Команда форума

SSL сертификат.


Если для домена еще не установлен сертификат, то информация о сертификате будет отсутствовать на странице настроек для сайта.



Если для домена удачно создан сертификат SSL, то при переходе к настройкам сайта ("Manage" из списка сайтов) в панели CyberPanel вы увидите информацию о том, что имеется SSL сертификат для сайта от Let's Encrypt, также будет указан срок когда действие SSL сертификата истечет.

Сообщение об удачном создании сертификата будет даже в том случае если невозможно в данный момент получить сертификат от Let's Encrypt. Автоматически будет создан в таком случае самоподписанный SSL сертификат. Внимательно проверяйте какой именно сертификат вы получили.





Самоподписанный сертификат:




Самоподписанный сертификат хранится там же где должен был бы храниться полноценный сертификат от Let's Encrypt.
А именно в папке /etc/letsencrypt/live/your_domain .com

 
Последнее редактирование:

sitecreator

Administrator
Команда форума

PHP



Одновременно можно использовать разные версии PHP, т.е. для каждого сайта может быть своя версия если это необходимо.
Конфигурация происходит довольно просто. Для каждой версии PHP основные параметры вводятся на вкладке "Basic" в соответствующие поля, а редактирование php.ini происходит на вкладке "Advanced".




После установки панели CyberPanel нужно отредактировать файл конфигурации php нужной версии.

ВАЖНО IMPORTANT
Учтите, что по-умолчанию конфигурация php содержит
Код:
short_open_tag = Off
Обязательно измените на:
Код:
short_open_tag = On



Любое изменение настроек PHP требует перезагрузки PHP. Поэтому после редактирования нажать "Сохранить изменения", далее - "Перезагрузка PHP".




Создание пользователя и сайта.



Все интуитивно понятно.

Нужно сперва создать профиль, который именуется в панели управления как Package. Или изменить дефолтный. Package будет использоваться при создании нового сайта, каждому сайту может быть назначен свой Package, который ставит лимиты на дисковое пространство и скорость передачи данных. По умолчанию эти лимиты очень низкие, например, для диска ограничение - 10 М. Из-за этого через файловый менеджер вы не сможете загружать большие файлы (через фтп сможете). Скорость передачи данных по дефолту тоже очень маленькая. Нет смысла проводить тестирование скорости веб-сервера с дефолтными ограничениями. Рекомендуется установить 0 (без ограничений). Веб-сервер нужно перезагрузить.



Создаете пользователя, например с username (именем пользователя) www-root. Далее создаете сайт, назначая для него пользователя www-root. SSL-сертификат можно добавить позднее.

На странице списка сайтов можно перейти в файловый менеджер для соответствующего сайта.








Файловый менеджер в панели управления доступен только для папки соответствующего сайта. Полазить по папкам вроде /usr у вас не получится, но для этого есть mc (Midnight Commander - консольный файловый менеджер). Файловый менеджер позволяет загружать несколько файлов методом перетаскивания. Например, в ISPmanager нет возможности загружать файлы перетаскиванием (drag & drop).
А вот в панели управления aaPanel файловый менеджер позволит вам заглянуть в любую папку.







Вид панели управления. Рекомендуется использовать английский в качестве языка интерфейса, т.к. русский часто получается длиннее чем необходимо, а потому ссылки вылазят за отведенные им пределы (налезают друг на друга) и пользоваться неудобно из-за этого.

 
Последнее редактирование:

SergeTkach

New member
Круто! Хотелось бы еще по LiteSpeed пошаговую инструкцию, если можно! :)
 
Верх